Training document for the company-wide automation solution
Totally Integrated Automation (TIA)

MODULE D6
PROFIBUS DP with
Master CPU 315-2DP / Slave CPU 315-2DP
This document was provided by Siemens A&D SCE (automation and drive technology, Siemens A&D Cooperates with Education) for training purposes. Siemens does not make any type of guarantee regarding its contents.

The passing on or duplication of this document, including the use and report of its contents, is only permitted within public and training facilities.

Exceptions require written permission by Siemens A&D SCE (Mr. Knust: E-Mail: michael.knust@hvr.siemens.de). Offences are subject to possible payment for damages caused. All rights are reserved for translation and any case of patenting or GM entry.

We thank the company Michael Dziallas Engineering and the instructors of vocational schools as well as further persons for the support with the production of the document.
The following symbols stand for the specified modules:

- Information
- Programming
- Example exercise
- Notes
1. FORWARD

The module D6 is assigned content wise to **Industrial field bus systems**.

Learning goal:

In this module, the reader should learn how the PROFIBUS DP is taken into operation with the CPU 315-2DP as a master and a CPU 315-2DP as a slave. The module shows the principle procedure by means of a short example.

Requirements:

For the successful use of this module, the following knowledge is assumed:

- Knowledge in the use of Windows 95/98/2000/ME/NT4.0
- Basics of PLC- Programming with STEP 7 (e.g. Module A3 - ‘Startup’ PLC programming with STEP 7)
- Basics of the PROFIBUS DP (e.g. Appendix IV – Basics of field bus systems with SIMATIC S7:300)
Required hardware and software

1. PC, Operating system Windows 95/98/2000/ME/NT4.0 with
   - Minimal: 133MHz and 64MB RAM, approx. 65 MB free hard disk space
   - Optimal: 500MHz and 128MB RAM, approx. 65 MB free hard disk space

2. Software STEP 7 V 5.x

3. MPI- Interface for the PC (e.g. PC- Adapter)

4. PLC SIMATIC S7-300 with the CPU 315-2DP with at least one digital in- and output.
   Example configuration:
   - Network: PS 307 2A
   - CPU: CPU 315-2DP
   - Digital inputs: DI 16x DC24V
   - Digital outputs: DO 16x DC24V / 0.5A

5. PLC SIMATIC S7-300 with the CPU 315-2DP and at least one digital in- and output.
   Example configuration:
   - Power supply: PS 307 2A
   - CPU: CPU 315-2DP
   - Digital inputs: DI 16x DC24V
   - Digital outputs: DO 16x DC24V / 0.5 A

6. PROFIBUS cable with 2 PROFIBUS slots
NOTES FOR THE OPERATION OF THE CPU 315-2DP

The CPU 315-2DP is a CPU that is made available with an integrated PROFIBUS DP interface. For the CPU 315-2DP, the following PROFIBUS protocol profiles are available at your disposal:

- DP- Interface as a master or slave in accordance with EN 50170. PROFIBUS-DP (Distributed I/O) is the protocol profile for the connection of distributed I/O/Field equipment with fast reaction time.

A further characteristic is that the addresses of the in- and output modules can be parameterized by this CPU.

The CPU capability is given with the following data:

- 16K statements, 48Kbyte RAM (integrated) 80Kbyte RAM
- 1024 Byte DI/DO
- 128 Byte AI/ AO
- 0.3 ms / 1K Instructions
- 64 Counters
- 128 Timers
- 2048 memory bits

Note: Here, the two CPUs 315-2DP are appointed to the PROFIBUS. One as a master and one as a slave.
4. COMMISSIONING THE PROFIBUS (MASTER CPU 315-2DP / SLAVE CPU 315-2DP)

In the following example, the commissioning of a mono master system with the CPU315-2DP as a master and another CPU 315-2DP as a slave is described.

For the testing of the configuration, a program will be written in which an input (SET) can be preset in each PLC. This byte is transferred over the PROFIBUS to the other PLC and can then be displayed over a display byte (DISPLAY).

Assignment list Master- CPU:
IB 0  SET    Input byte
IB 40 Comm_IB1  Input communication Byte1
QB 4  DISPLAY  Display byte
QB 40 Comm_QB1  Output communication Byte1

Assignment list Slave- CPU:
IB 0  SET    Input byte
IB 40 Comm_EB1  Input communication Byte1
QB 4  DISPLAY  Display byte
QB 40 Comm_QB1  Output communication Byte1

For the connection of the two CPU315-2DP, whereby one is set as a master and the other as a slave, the following steps must be followed.

1. The central tool in STEP 7 is the SIMATIC Manager, which is opened here with a double click ( → SIMATIC Manager).
2. **STEP 7-** Programs are administered in projects. Such a project will be created (→ File → New).

3. Give the project the **Name CPU315_CPU315** (→ CPU315_CPU315 → OK)
4. Highlight your project and insert a **PROFIBUS Subnet** (→ CPU315_CPU315 → Insert → Subnet → PROFIBUS).

5. Then insert a **SIMATIC 300-Station** (→ Insert → Station → SIMATIC 300-Station).
6. Modify the name of the station to **Slave** (→ Slave).

7. Open the configuration tool for the **Hardware** with a double click (→ Hardware).
8. Open the hardware catalog with a click on the symbol \[\text{symbo} \rightarrow \text{symbol}].

There you will see the directories are divided into the following:
- PROFIBUS-DP, SIMATIC 300, SIMATIC 400 and SIMATIC PC Based Control,
all module racks, modules and interface modules for the configuration of your hardware configuration are made available.
Insert a Rail with a double click( \(\rightarrow\) SIMATIC 300 \(\rightarrow\) RACK-300 \(\rightarrow\) Rail).

After the insert, a configurations table for the configuration of the Rack 0 appears automatically.
9. Now all modules can be chosen out of the hardware catalog and inserted into the configuration table and are also inserted into your rack.

To insert, you must click on the name of the respective module, hold the mouse button and Drag & Drop the module into a line of the configurations table. We will begin with the power supply **PS 307 2A** (SIMATIC 300 → PS-300 → PS 307 2A).

![Diagram of configuration](image)

**Note:** If your hardware differs from what is shown above, then you must select the appropriate modules from the catalog and insert them into the rack. The part numbers of the individual modules, which are found on the components, are indicated in the footer of the catalog.
10. In the next step, we drop the CPU 315-2DP into the second card location. This allows for the part number and version of the CPU to be read off. (→ SIMATIC 300 → CPU-300 → CPU 315-2DP → 6ES7 315-2AF03-0AB0 → V1.1).

11. By the entering of the CPU, the following window appears, in which you assign a PROFIBUS address to the CPU 315-2DP and must already choose the first PROFIBUS net. When you want to alter the parameter of the PROFIBUS net, you must highlight it and then click on Properties (→ Properties).
12. Now you can choose the **Highest PROFIBUS Address** (here → 126), the **Transmission Rate** (here → 1,5 Mbit/s) and the **Profile** (here → DP). (→ OK).

13. In the next step we see the input module for 16 inputs on fourth slot. There the order number of the module is read off the front (→ SIMATIC 300 → DI-300 → SM 321 DI16xDC24V).

---

**Note:** Slot number 3 is reserved for interface modules and remains empty. The order number of the module is displayed in the footer of the catalog.
14. In the next step we see the output module for 16 outputs on fifth slot. There the order number of the module is read off the front (→ SIMATIC 300 → DO-300 → SM 322 DO16xDC24V/0.5A).

**Note:** The order number of the module is displayed in the footer of the catalog.
15. Choose the PROFIBUS interface ‘DP’ with a double click in order to change it to DP- Slave (DP).

16. Choose Operating Mode and change DP to DP slave (Operation Mode → DP slave).
17. In the following dialog the data range for the communication to the master can be set.

Mode: Master/Slave
Output range: Q40; Length 1 byte; Consistency by the unit of a word
Input range: I40; Length 1 byte; Consistency by the unit of a word

This adjustment is then accepted with OK (→ OK).
18. The configuration table should first be saved and compiled with a click on \(\text{F4}\). Then the hardware configuration is closed with a click on \(\text{F5}\) (∴ \(\text{F4}\) → \(\text{F5}\)).

19. In SIMATIC Manager, a further SIMATIC 300-Station is inserted for the master (∴ SIMATIC Manager → Insert → Station → SIMATIC 300-Station).
20. Modify the name of the station to **Master**. (→ **Master**)

21. Open the configuration tool for the **Hardware** with a double click (→ **Hardware**).
22. Open the hardware catalog with a click on the symbol \( \rightarrow \). There you will see the directories are divided into the following:
- PROFIBUS-DP, SIMATIC 300, SIMATIC 400 and SIMATIC PC Based Control,
- all module racks, modules and interface modules for the configuration of your hardware configuration are made available.

Insert a **Rail** with a double click\( \rightarrow \) SIMATIC 300 \( \rightarrow \) RACK-300 \( \rightarrow \) Rail).

After the insert, a configurations table for the configuration of the Rack 0 appears automatically.
23. Now all modules can be chosen out of the hardware catalog and inserted into the configuration table and are also inserted into your rack. To insert, you must click on the name of the respective module, hold the mouse button and Drag & Drop the module into a line of the configurations table. We will begin with the power supply PS 307 2A (SIMATIC 300 → PS-300 → PS 307 2A).

Note: If your hardware differs from what is shown above, then you must select the appropriate modules from the catalog and insert them into the rack. The part numbers of the individual modules, which are found on the components, are indicated in the footer of the catalog.
24. In the next step, we drop the CPU 315-2DP into the second card location. This allows for the part number and version of the CPU to be read off. (→ SIMATIC 300 → CPU-300 → CPU 315-2DP → 6ES7 315-2AF03-0AB0 → V1.1).

![Image of software configuration window]

25. By the entering of the CPU, the following window appears, in which you assign a PROFIBUS address to the CPU 315-2DP and must already choose the first PROFIBUS net. You can accept the setting. (→ OK)
26. In the next step we see the input module for 16 inputs on fourth slot. There the order number of the module is read off the front (→ SIMATIC 300 → DI-300 → SM 321 DI16xDC24V).

Note: Slot number 3 is reserved for interface modules and remains empty. The order number of the module is displayed in the footer of the catalog.
27. In the next step we see the output module for 16 outputs on fifth slot. There the order number of the module is read off the front (SIMATIC 300 → DO-300 → SM 322 DO16xDC24V/0.5A).

**Note:** The order number of the module is displayed in the footer of the catalog.
28. Then a bar chart for the **Master system** is shown to the right of the CPU315-2DP, in which you can arrange the PROFIBUS. This happens by clicking the desired module (Here the **CPU315-2DP as Configured Stations**) from the hardware catalog in path **CPU31x**. By Drag & Drop click with the mouse, it can be dropped into the master system (→ PROFIBUS DP → Configured Stations → CPU31x).
29. By the entering of the CPU315-2DP as a slave, the following window is displayed in which you must **Connect** the already configured slave (PROFIBUS- Address 2) to the CPU 315-2DP as master (→ Connect).

![Diagram of DP slave properties window]

30. After the connection, the CPU315-2DP is entered as an active connection. This connection is then accepted with **OK** (→ OK).

![Diagram of DP slave properties window with active connection]
31. In the following dialog, the data range can be adjusted for the communication between the master and slave.

**From master to slave:**
Mode: Master/Slave
Output range master: Q40; Length 1 byte; Consistency by the unit of a byte
Input range slave: I40; Length 1 byte; Consistency by the unit of a byte

**From slave to master:**
Mode: Master/Slave
Output range slave: Q40; Length 1 byte; Consistency by the unit of a byte
Input range master: I40; Length 1 byte; Consistency by the unit of a byte

This adjustment is then accepted with **OK (→ OK)**.
32. The configuration table should first be saved and compiled with a click on $\text{Save}$ ($\rightarrow$). Then the hardware configuration is closed with a click on $\times$ ($\rightarrow$ $\times$).

33. From the SIMATIC Manager, open the block OB1 for the Slave with a double click ($\rightarrow$ OB1).
34. By the properties of the OB1, change the **Created in Language** to **STL** and accept with 'OK' (→ STL → OK).

![Properties - Organization Block](image1.png)

35. With **LAD, STL, FBD: Program blocks**, you now have an editor which gives you the possibility to generate your STEP 7- Program. Here the organization block OB1 was already opened with the first network. In order to generate your first logical operation, you must highlight the first network. Now you can write your first STEP 7- Program. Several programs can usually be divided into networks. Open a new network by clicking on the network symbol. The STEP 7- Program to be tested can now be saved with (→ ).

![LAD/STL/FBD - OB1 - CPU313I CPU315SIameCPU CPU3152 DP](image2.png)
36. From the SIMATIC Manager, open the block OB1 for the Master with a double click (→ OB1).

37. By the properties of the OB1, change the Created in Language to STL and accept with ‘OK’ (→ STL → OK).
38. With **LAD, STL, FBD: Program blocks**, you now have an editor which gives you the possibility to generate your STEP 7-Program. Here the organization block OB1 was already opened with the first network. In order to generate your first logical operation, you must highlight the first network. Now you can write your first STEP 7-Program. Several programs can usually be divided into networks. Open a new network by clicking on the network symbol \(\text{Network symbol}\). The STEP 7-Program to be tested can now be saved with \(\text{Save button}\). (→ \(\text{Save button}\)).

Now the configuration and connection of both partners is completed. The output word 40 from the master is now written to the slave in input word 40. The output word 40 from the slave is now read from the master and written in the input work 40.

**Note:** By activation of both CPUs a synchronization error can arise, so that both CPUs show a system error (SF) and will go into STOP mode. Therefore it means that both CPUs never switch to high at the same time and the beginning run to the slave of the master fails and returns.

By this error, the CPUs try to call the OB82 (Diagnostic alarm). If it is not available, the CPUs go into STOP mode! This problem can be repaired by an empty OB82 being downloaded into both CPUs.
39. In SIMATIC Manager, choose the folder Blocks to the Master station. Insert a new Organization Block (→ Master → SIMATIC Manager → Blocks → Insert → S7 Block → Organization Block).

40. Adjust the Name to OB82 and accept with OK (→ Name → OB82 → OK).
41. In **SIMATIC Manager**, choose the folder Blocks to the **Slave** station. Insert a new **Organization Block** (→ Master → SIMATIC Manager → Blocks → Insert → S7 Block → Organization Block).

42. Adjust the **Name** to **OB82** and accept with **OK** (→ Name → OB82 → OK)
43. In SIMATIC Manager, download the station **Master** into the PLC. The mode switch of the CPU must be on STOP and the PC-Adapter must be connected with the MPI interface!

(→ CPU315_2DP → ).

44. In SIMATIC Manager, download the station **Slave** into the PLC. The mode switch of the CPU must be on STOP and the PC-Adapter must be connected with the MPI interface!

(→ CPU315_2DP → ).

45. Now switch the slave to RUN. If it starts up, then also through the switching of the mode switch on the master to RUN, the program is started.